Функция ПолучитьДень(ИсходнаяДата, КоличествоПрибавляемыхДней)
	
	Запрос = Новый Запрос("
	|ВЫБРАТЬ 
	|ДОБАВИТЬКДАТЕ(&ИсходнаяДата, ДЕНЬ, &Количество) как Дата");
	
	Запрос.УстановитьПараметр("ИсходнаяДата", ИсходнаяДата);
	Запрос.УстановитьПараметр("Количество", КоличествоПрибавляемыхДней);

Добавлено анонимнусом 26.04.2019 10:20:22

Просмотреть запись целиком.


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Для Каждого ТипМнЧ Из СтрРазделить("Справочники,Документы,ЖурналыДокументов,Отчеты,Обработки,ПланыВидовХарактеристик,ПланыСчетов,ПланыВидовРасчета,РегистрыСведений,РегистрыНакопления,РегистрыБухгалтерии,РегистрыРасчета,Бизн

Добавлено анонимнусом 23.04.2019 01:55:38

Просмотреть запись целиком.


Ограничение по структуре

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	
	Если РольДоступна("ПолныеПрава") или ДопХарактеристикаАХО() тогда
		Возврат;
	КонецЕсли;
	Запрос = новый Запрос;
	Запрос.Текст =  "
		|ВЫБРАТЬ
		|	Пользователи.ФизическоеЛицо КАК ФизическоеЛицо,
		|	Пользователи.Ссыл

Ограничение по структуре

Добавлено анонимнусом 18.04.2019 12:06:31

Просмотреть запись целиком.


После

ВЫБРАТЬ
	ЕстьКоэффициент.Ссылка.Дата КАК Дата,
	ЕстьКоэффициент.Ссылка.Контрагент КАК Контрагент,
	ЕстьКоэффициент.Ссылка КАК Реализация,
	ЕстьКоэффициент.Номенклатура КАК Номенклатура,
	ЕстьКоэффициент.Ссылка.Склад КАК Склад,
	МАКСИМУМ(ЕстьКоэффициент.Ссылка.Контрагент.ИС_КоэффициентТепловойЭ

Почему я не могу вместо ГДЕ ЕстьКоэффициент.Количество = 0 Вставить отбор ИМЕЮЩИЕ СУММА(ЕстьКоэффициент.Сумма) = 0 Не возвращается в результате запроса вообще ничего, если сделать замену. Почему?

Добавлено анонимнусом 17.04.2019 09:41:53

Просмотреть запись целиком.


После

ВЫБРАТЬ
	МАКСИМУМ(ЕстьКоэффициент.Ссылка.Контрагент.ИС_КоэффициентТепловойЭнергии) КАК КоэффициентТепловойЭнергии,
	ЕстьКоэффициент.Ссылка.Контрагент КАК Контрагент,
	ЕстьКоэффициент.Ссылка КАК Реализация,
	СУММА(ЕстьКоэффициент.Сумма) КАК СуммаСКоэффициентомБезНДС,
	СУММА(ЕСТЬNULL(ЕстьКоэффици

Почему я не могу вместо ГДЕ ЕстьКоэффициент.Количество = 0 Вставить отбор ИМЕЮЩИЕ СУММА(ЕстьКоэффициент.Сумма) = 0 Не возвращается в результате запроса вообще ничего, если сделать замену. Почему?

Добавлено анонимнусом 17.04.2019 09:21:52

Просмотреть запись целиком.


После

ВЫБРАТЬ
	МАКСИМУМ(ЕстьКоэффициент.Ссылка.Контрагент.ИС_КоэффициентТепловойЭнергии) КАК КоэффициентТепловойЭнергии,
	ЕстьКоэффициент.Ссылка.Контрагент КАК Контрагент,
	ЕстьКоэффициент.Ссылка КАК Реализация,
	СУММА(ЕстьКоэффициент.Сумма) КАК СуммаСКоэффициентомБезНДС,
	СУММА(ЕСТЬNULL(ЕстьКоэффици

Добавлено анонимнусом 17.04.2019 07:07:55

Просмотреть запись целиком.


как стало

ВЫБРАТЬ
	ДелегированиеИсполнителейЗадач.Пользователь КАК Пользователь
	ПОМЕСТИТЬ ВТ
ИЗ
	РегистрСведений.ДелегированиеИсполнителейЗадач КАК ДелегированиеИсполнителейЗадач
ГДЕ
	ДелегированиеИсполнителейЗадач.Замещающий = &Замещающий
	И ДелегированиеИсполнителейЗадач.Период <= &ТекущаяДата
	И Д

Добавлено Ngoncharow 17.04.2019 07:04:34

Просмотреть запись целиком.


как было

ВЫБРАТЬ 
	ЗадачаИсполнителя.Ссылка КАК Ссылка,
	ЗадачаИсполнителя.ПометкаУдаления КАК ПометкаУдаления,
	ЗадачаИсполнителя.Номер КАК Номер,
	ЗадачаИсполнителя.Дата КАК Дата,
	ЗадачаИсполнителя.БизнесПроцесс КАК БизнесПроцесс,
	ЗадачаИсполнителя.ТочкаМаршрута КАК ТочкаМаршрута,
	ЗадачаИсполните

Добавлено Ngoncharow 17.04.2019 07:03:48

Просмотреть запись целиком.


чек

ВЫБРАТЬ
	МАКСИМУМ(РеализацияТоваровУслугТовары.Ссылка.Контрагент.ИС_КоэффициентТепловойЭнергии) КАК КоэффициентТепловойЭнергии,
	РеализацияТоваровУслугТовары.Ссылка.Контрагент КАК Контрагент,
	РеализацияТоваровУслугТовары.Ссылка КАК Реализация,
	СУММА(РеализацияТоваровУслугТовары.Сумма) КАК Сумм

Зачем тут временные таблицы, если ты далее все по <Выбор Когда> считаешь ? Чем обусловлено их использование ?

Добавлено Кирилл Суптелов 17.04.2019 02:34:00

Просмотреть запись целиком.


БП30

ВЫБРАТЬ
	МАКСИМУМ(РеализацияТоваровУслугТовары.Ссылка.Контрагент.ИС_КоэффициентТепловойЭнергии) КАК КоэффициентТепловойЭнергии,
	РеализацияТоваровУслугТовары.Ссылка.Контрагент КАК Контрагент,
	РеализацияТоваровУслугТовары.Ссылка КАК Реализация,
	СУММА(РеализацияТоваровУслугТовары.Сумма) КАК Сумм

Добавлено анонимнусом 17.04.2019 02:11:27

Просмотреть запись целиком.


#Область СведенияОВнешнейОбратботке
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = Новый Структура;
	МассивНазначений = Новый Массив;
	МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
	ПараметрыРегист

Добавлено анонимнусом 16.04.2019 23:51:05

Просмотреть запись целиком.


#Область СведенияОВнешнейОбратботке
Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = Новый Структура;
	МассивНазначений = Новый Массив;
	МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
	ПараметрыРегист

Добавлено анонимнусом 16.04.2019 23:51:01

Просмотреть запись целиком.


	//////Контактные данные контрагента
	Запрос = ГЛБаза.NewObject("Запрос");
	Запрос.Текст = "ВЫБРАТЬ
	|	КонтактнаяИнформация.Объект,
	|	КонтактнаяИнформация.Тип,
	|	КонтактнаяИнформация.Вид,
	|	КонтактнаяИнформация.Представление КАК КонтактнаяИнформацияПредставление,
	|	КонтактнаяИнформация.По

Добавлено анонимнусом 16.04.2019 06:43:29

Просмотреть запись целиком.


 // БСП 2.0 и старше
 ОбщегоНазначения.ЗначениеРеквизитаОбъекта();
 ОбщегоНазначения.ЗначенияРеквизитовОбъектов();

Добавлено анонимнусом 15.04.2019 12:12:32

Просмотреть запись целиком.



&НаСервере
Функция СформироватьПечатнуюФормуТОРГ12() 
		
	ТабличныйДокумент = Новый ТабличныйДокумент;
	ДанныеДляПечати = ПолучитьДанныеДляПечатнойФормыТОРГ12();
	ЗаполнитьТабличныйДокументТОРГ12(ТабличныйДокумент, ДанныеДляПечати);

Возврат ТабличныйДокумент;
	
КонецФункции

Функция По

Добавлено анонимнусом 15.04.2019 06:56:42

Просмотреть запись целиком.



&НаСервере
Функция СформироватьПечатнуюФормуТОРГ12() 
		
	ТабличныйДокумент = Новый ТабличныйДокумент;
	ДанныеДляПечати = ПолучитьДанныеДляПечатнойФормыТОРГ12();
	ЗаполнитьТабличныйДокументТОРГ12(ТабличныйДокумент, ДанныеДляПечати);

Возврат ТабличныйДокумент;
	
КонецФункции

Функция По

Добавлено анонимнусом 15.04.2019 04:42:37

Просмотреть запись целиком.


			   Результат= Запрос.Выполнить().Выбрать();
			   Счетчи=0;
			   Всего = Результат.Количество();
			   Пока Результат.Следующий() цикл
				   Счетчи = Счетчи + 1 ;
				   Состояние(Строка(Счетчи) +  " из "+ Строка(Всего));
				   НашДок= Результат.Регистратор.ПолучитьОбъект();
							 Наш

Добавлено анонимнусом 12.04.2019 11:07:55

Просмотреть запись целиком.


&После("ДобавитьКомандыПечати")
Процедура ЮН_ДобавитьКомандыПечати(КомандыПечати)
	//Заменяемая печатная форма определяется по идентификатору
	ИскомаяКоманда = КомандыПечати.Найти("СчетНаОплату", "Идентификатор");
	Если ИскомаяКоманда <> Неопределено Тогда
		ИскомаяКоманда.МенеджерПечати = "Обр

Добавлено анонимнусом 12.04.2019 08:08:29

Просмотреть запись целиком.


&После("ДобавитьКомандыПечати")
Процедура ЮН_ДобавитьКомандыПечати(КомандыПечати)
	//Новая печатная форма
	КомандаПечати = КомандыПечати.Добавить();
	КомандаПечати.МенеджерПечати = "Обработка.ЮН_ТоварнаяНакладнаяТОРГ12БезСерий";
	КомандаПечати.Идентификатор = "ТОРГ12";
	КомандаПечати.Представл

Добавлено анонимнусом 12.04.2019 08:04:10

Просмотреть запись целиком.


Процедура ПриСозданииНаСервере(Форма) Экспорт
	НовыйЭлементФормы = Форма.Элементы.Вставить("ЮН_БизнесРегион", Тип("ПолеФормы"), Форма.Элементы.ГруппаРеквизиты, Форма.Элементы.ГруппаПараметрыПроизводственногоПодразделения);
	НовыйЭлементФормы.Вид = ВидПоляФормы.ПолеВвода;
	НовыйЭлементФормы.ПутьКД

Добавлено анонимнусом 12.04.2019 08:01:22

Просмотреть запись целиком.