xdtoСправочник = сшпОбщегоНазначения.ПолучитьОбъектXDTO(Перечисления.сшпФорматыСообщений.XML, ОбъектСообщение.Body);

Попытка		
    
    ID = Строка(xdtoСправочник.ID);		
    
    НачатьТранзакцию();
    
    БлокировкаДанных = Новый БлокировкаДанных;
    ЭлементБлокировки = БлокировкаДанны

Добавлено анонимнусом 22.06.2017 03:29:31

Просмотреть запись целиком.


&НаСервере 
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
		
	УправлениеПечатью.ПриСозданииНаСервере(ЭтаФорма)	
	
КонецПроцедуры 
 
&НаКлиенте 
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)
	
	УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФор

Добавлено анонимнусом 21.06.2017 10:04:00

Просмотреть запись целиком.


РезультатОбработки.ClassID = "Partner";	

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|	упИдентификаторыОбмена.Идентификатор КАК ID,
|	Партнеры.Код КАК Code,
|	ИСТИНА КАК Addcounterparty,
|	Партнеры.Наименование КАК Name,
|	Партнеры.НаименованиеПолное КАК FullName,
|	Партнеры.Родитель К

Добавлено анонимнусом 20.06.2017 03:12:26

Просмотреть запись целиком.


ВЫБРАТЬ   // список допустимых ЦФО трейд маркетинга
                Ссылка
ПОМЕСТИТЬ втЦФОТрейдМаркетинга
ИЗ
                Справочник.ЦФО
ГДЕ НЕ ПометкаУдаления
                И (Ссылка В ИЕРАРХИИ (&ЦП_ДистрибуцияУкраина)  // элемент спр-ка ЦФО Код:"000000002", Наименование:"ЦП Дистрибуция 

Добавлено анонимнусом 19.06.2017 06:38:16

Просмотреть запись целиком.


фыва

Добавлено анонимнусом 18.06.2017 19:26:42

Просмотреть запись целиком.


	Запрос = Новый Запрос("ВЫБРАТЬ ПЕРВЫЕ 10
	                      |	Товары.Код,
	                      |	Товары.Наименование,
	                      |	Товары.Артикул,
	                      |	Товары.НомерКросс,
	                      |	Товары.НомерКросс1,
	                      |	Товары.НомерКр

Добавлено анонимнусом 16.06.2017 06:01:30

Просмотреть запись целиком.


xdtoСправочник = сшпОбщегоНазначения.ПолучитьОбъектXDTO(Перечисления.сшпФорматыСообщений.XML, ОбъектСообщение.Body);

Попытка		
    
    ID = Строка(xdtoСправочник.ID);		
    
    НачатьТранзакцию();
    
    БлокировкаДанных = Новый БлокировкаДанных;
    ЭлементБлокировки = БлокировкаДанны

Добавлено анонимнусом 15.06.2017 02:11:11

Просмотреть запись целиком.


Номенклатура = Справочники.Номенклатура.ПолучитьСсылку(новый 
    УникальныйИдентификатор(НоменклатураКод));
Если Найти(Строка(Номенклатура),"не найден") > 0 Тогда 
    Номенклатура = Справочники.Номенклатура.НайтиПоКоду(НоменклатураКод);
КонецЕсли;	

Добавлено анонимнусом 13.06.2017 18:52:34

Просмотреть запись целиком.


Если не ИнтерфейсРМ.ПопыткаДействияСОбъектом(ОткрытиеСмены,"Объект.Записать(РежимЗаписиДокумента.Проведение)") Тогда
	Если ЭтоПерваяКассоваяСмена() Тогда
		Попытка
			УправлениеСерверамиПриложений.СоздатьЛокальнуюФайловуюБазу();	

Добавлено анонимнусом 12.06.2017 09:21:24

Просмотреть запись целиком.


ПротоколРасчетов.СуммаФакт = СуммаФакт;
ПротоколРасчетов.Записать(РежимЗаписиДокумента.Проведение);

Добавлено анонимнусом 11.06.2017 21:05:16

Просмотреть запись целиком.


ВЫБРАТЬ
	ЗаказыПокупателейОстатки.ЗаказПокупателя КАК ЗаказПокупателя,
	ЗаказыПокупателейОстатки.ЗаказПокупателя.Дата КАК ЗаказПокупателяДата,
	ЗаказыПокупателейОстатки.Номенклатура КАК Номенклатура,
	ЗаказыПокупателейОстатки.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатуры,
	ЗаказыПок

Добавлено анонимнусом 09.06.2017 12:04:19

Просмотреть запись целиком.


ВЫБРАТЬ
	СвязиПриходовИРасходов.Номер
	
ИЗ
	РегистрСведений.СвязиПриходовИРасходов КАК СвязиПриходовИРасходов

СГРУППИРОВАТЬ ПО
	СвязиПриходовИРасходов.Номер

ИМЕЮЩИЕ
	КОЛИЧЕСТВО(СвязиПриходовИРасходов.Дата) > 1 И
	ГОД(МИНИМУМ(СвязиПриходовИРасходов.Дата)) = ГОД(МАКСИМУМ(СвязиПриходовИРас

Добавлено анонимнусом 02.06.2017 08:31:57

Просмотреть запись целиком.


Если Не РезультатКомандыФискализация Тогда // проверим на "НОМЕР ФД ИЗМЕНИЛСЯ"
	Если ТипЗнч(ПараметрыВыходные) = Тип("Структура") Тогда
		Ошибки = Ошибки;
		Если ПараметрыВыходные.Свойство("ОписаниеОшибки", Ошибки) Тогда
			Если ТипЗнч(Ошибки) = Тип("Массив")  Тогда
				СтрОшибка = СтрСоединить

Добавлено анонимнусом 26.05.2017 14:12:59

Просмотреть запись целиком.


Если Не РезультатКомандыФискализация Тогда // проверим на "НОМЕР ФД ИЗМЕНИЛСЯ"
		Если ТипЗнч(ПараметрыВыходные) = Тип("Структура") Тогда
			Ошибки = Ошибки;
			Если ПараметрыВыходные.Свойство("ОписаниеОшибки", Ошибки) Тогда
				Если ТипЗнч(Ошибки) = Тип("Массив")  Тогда
					СтрОшибка = СтрСоед

Добавлено анонимнусом 26.05.2017 14:12:21

Просмотреть запись целиком.


Функция глДатьСпрПоФразе(пСтрока, пРодитель=Неопределено) Экспорт
	Перем РЭлемент,РОбъект;
	
	РЭлемент = Справочники.Показатели.НайтиПоНаименованию(пСтрока, Истина);
	Если РЭлемент = Справочники.Показатели.ПустаяСсылка() Тогда
		РОбъект = Справочники.Показатели.СоздатьЭлемент();
		РОбъект.Наим

Добавлено анонимнусом 24.05.2017 15:02:21

Просмотреть запись целиком.


23


Процедура ПриОткрытии(Отказ)
	
	СформироватьАвтоНаименование();
	ЗаполнитьEmail();
	ЗаполнитьSMS();
	
КонецПроцедуры

Добавлено анонимнусом 24.05.2017 11:14:34

Просмотреть запись целиком.



&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	СформироватьАвтоНаименование();
	ЗаполнитьEmail();
	ЗаполнитьSMS();
	
КонецПроцедуры

Добавлено анонимнусом 24.05.2017 11:14:17

Просмотреть запись целиком.


ПротоколРасчетов.Записать();

Добавлено анонимнусом 24.05.2017 10:12:57

Просмотреть запись целиком.


			Ссылка = XMLЗначение(Тип("ДокументСсылка.РеализацияТоваровУслуг"),ТекСтрока.гуид);
			Если ЗначениеЗаполнено(Ссылка.Номер) Тогда 
				ДокОб = Ссылка.ПолучитьОбъект();
			Иначе
				//гуид = Новый УникальныйИдентификатор(ТекСтрока.Гуид);
				ДокОб = Документы.РеализацияТоваровУслуг.СоздатьДоку

Добавлено анонимнусом 22.05.2017 04:22:41

Просмотреть запись целиком.


			Ссылка = XMLЗначение(Тип("ДокументСсылка.РеализацияТоваровУслуг"),ТекСтрока.гуид);
			Если ЗначениеЗаполнено(Ссылка.Номер) Тогда 
				ДокОб = Ссылка.ПолучитьОбъект();
			Иначе
				гуид = Новый УникальныйИдентификатор(ТекСтрока.Гуид);
				ДокОб = Документы.РеализацияТоваровУслуг.СоздатьДокуме

Добавлено анонимнусом 22.05.2017 04:15:04

Просмотреть запись целиком.