//Создание объекта типа Запрос
	Запрос = СоздатьОбъект("Запрос");
	ТекстЗапроса = 
	"//{{ЗАПРОС(Сформировать2)
	|Период с НачДата по КонДата;
	|
	|ЮрЛицо 	= Регистр.Покупатели.Фирма.ЮрЛицо, Регистр.Поставщики.Фирма.ЮрЛицо;
	|Контрагент = Регистр.Покупатели.Договор.Владелец, Регистр.Поставщики.Договор.Владелец;
	|Договор 	= Регистр.Покупатели.Договор, Регистр.Поставщики.Договор;
	|Сум 		= Регистр.Покупатели.СуммаРуб, Регистр.Поставщики.СуммаРуб;
	|ТекДок 	= Регистр.Покупатели.ТекущийДокумент, Регистр.Поставщики.ТекущийДокумент;
	|
	|Функция СумНачОст = НачОст(Сум);
	|Функция СумПриход = Приход(Сум);
	|Функция СумРасход = Расход(Сум);
	|Функция СумКонОст = КонОст(Сум);
	|
	|Группировка ТекДок;
	|
	|Условие(ЮрЛицо 	= ВыбОрганизация);
	|Условие(Контрагент = ВыбКонтрагент);
	|Условие(Договор 	в ВыбДоговор);
	|"//}}ЗАПРОС
	;
	// Если ошибка в запросе, то выход из процедуры
	Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
		Возврат;
	КонецЕсли;
	
	Пока Запрос.Группировка(1) = 1 Цикл
		     
		Докум = Запрос.ТекДок;
		Если Докум.Выбран() = 0 Тогда
		    Продолжить;
		КонецЕсли;     
                           
		// определим тип операции
		ВидДокум = Докум.ПредставлениеВида();
		
		Если СокрЛП(Лев(ВидДокум, 10)) = "Реализация" Тогда		
			ТекстОперации = "Реализация";
			
		ИначеЕсли СокрЛП(Лев(ВидДокум, 11)) = "Поступление" Тогда		
			ТекстОперации = "Поступление";

		ИначеЕсли СокрЛП(Лев(ВидДокум, 7)) = "Возврат" Тогда		
			ТекстОперации = "Возврат";
			
		ИначеЕсли СокрЛП(Лев(ВидДокум, 13)) = "Корректировка" Тогда		
			ТекстОперации = "Корректировка";

		ИначеЕсли СокрЛП(Лев(ВидДокум, 13)) = "Ввод остатков" Тогда		
			ТекстОперации = "Ввод остатков";
			
		ИначеЕсли СокрЛП(Лев(ВидДокум, 24)) = "Приходный кассовый ордер" Тогда
			Если Докум.КодОперации = глКО.ОплатаОтПокупателя Тогда
				ТекстОперации = "Оплата";
			ИначеЕсли Докум.КодОперации = глКО.ВозвратОплатыОтПоставщика Тогда
				ТекстОперации = "Возврат";
			Иначе
				ТекстОперации = "";	
			КонецЕсли;

		ИначеЕсли СокрЛП(Лев(ВидДокум, 24)) = "Расходный кассовый ордер" Тогда		
			Если Докум.КодОперации = глКО.ОплатаПоставщику Тогда
				ТекстОперации = "Оплата";
			ИначеЕсли Докум.КодОперации = глКО.ВозвратОплатыПокупателю Тогда
				ТекстОперации = "Возврат";
			Иначе
				ТекстОперации = "";	
			КонецЕсли;

		ИначеЕсли СокрЛП(Лев(ВидДокум, 29)) = "Строка выписки банка (приход)" Тогда		
			Если Докум.КодОперации = глКО.ОплатаПоставщику Тогда
				ТекстОперации = "Оплата";
			ИначеЕсли Докум.КодОперации = глКО.ВозвратОплатыПокупателю Тогда
				ТекстОперации = "Возврат";
			Иначе
				ТекстОперации = "";	
			КонецЕсли;
			
		ИначеЕсли СокрЛП(Лев(ВидДокум, 29)) = "Строка выписки банка (расход)" Тогда		
			Если Докум.КодОперации = глКО.ОплатаПоставщику Тогда
				ТекстОперации = "Оплата";
			ИначеЕсли Докум.КодОперации = глКО.ВозвратОплатыПокупателю Тогда
				ТекстОперации = "Возврат";
			Иначе
				ТекстОперации = "";	
			КонецЕсли;
			
		ИначеЕсли СокрЛП(Лев(ВидДокум, 29)) = "Строка аванс. отчета (оплата)" Тогда					
			ТекстОперации = "Оплата";
			
		Иначе              
			ТекстОперации = "";
			
		КонецЕсли;
		                             

Добавлено анонимнусом 30.05.2018 16:41:28