ЯРисуюРамкуПоКоординатамВБраузере

	Ванесса.ДобавитьШагВМассивТестов(ВсеТесты, "ЯРисуюРамкуПоКоординатамВБраузере(ТабПарам)",
		"ЯРисуюРамкуПоКоординатамВБраузере",
		"И я рисую рамку по координатам в браузере
		|		|'left'|'100'|
		|		|'top'|'100'|
		|		|'width'|'200'|
		|		|'height'|'200'|
		|		|'color'|'red'|
		|		|'size'|'

Добавлено анонимнусом 26.10.2020 08:32:32

Просмотреть запись целиком.


Мобильная платформа. Поле HTML документа

&НаКлиенте
Перем БраузерУпрощеннойФормыВвода;

&НаКлиенте
Процедура ЭлементБраузераУпрощеннойФормыВводаДокументСформирован(Элемент)

   БраузерУпрощеннойФормыВвода = Элементы.ЭлементБраузераУпрощеннойФормыВвода.Document.defaultView;
   
КонецПроцедуры

&НаКлиенте
Процедура ЭлементБраузера

Добавлено анонимнусом 26.10.2020 08:16:44

Просмотреть запись целиком.


Процедура УставновитьСвойствоЭлементов(СписокСтрока, Свойство)
	Для Каждого Элемент Из СтрРазделить(СписокСтрока, ",") Цикл
		Элементы[СокрЛП(Элемент)][Свойство] = НЕ Маркер;
	КонецЦикла;
КонецПроцедуры

Добавлено анонимнусом 22.10.2020 13:50:16

Просмотреть запись целиком.


&НаКлиенте
Процедура Вызов(Команда)
	Ключ = "D75279DC-370A-48B1-B29A-D84AA15D6184";
	Ресурс = "api.dellin.ru";
	мТерминалы = "/v3/public/terminals.json";
	Соединение = Новый HTTPСоединение(Ресурс, 80);
	
	СсылкаНаФайл = ЗабратьФайл(Соединение, Ключ, Ресурс, мТерминалы);
	Файл = Новый Файл(Сс

Добавлено анонимнусом 21.10.2020 08:39:31

Просмотреть запись целиком.


ВЫБРАТЬ
	ЗаказыМатериаловВПроизводство.*
ИЗ 
	РегистрНакопления.ЗаказыМатериаловВПроизводство КАК ЗаказыМатериаловВПроизводство
ГДЕ
	ЗаказыМатериаловВПроизводство.Распоряжение = &ЭтапПроизводства
	И ЗаказыМатериаловВПроизводство.ВидДвижения = ЗНАЧЕНИЕ(ВидДвиженияНакопления.Расход)
	И НЕ Заказ

Добавлено анонимнусом 19.10.2020 12:48:34

Просмотреть запись целиком.


АУФ

ВЫБРАТЬ
	ТаблицаШапки.Ссылка КАК Документ,
	ТаблицаШапки.Партнер КАК Партнер,
	МАКСИМУМ(ТаблицаШапки.Дата) КАК Дата
ПОМЕСТИТЬ ВтТаблицаОтбора
ИЗ
	Документ.ПоступлениеБезналичныхДенежныхСредств КАК ТаблицаШапки
ГДЕ
	1 В
			(ВЫБРАТЬ ПЕРВЫЕ 1
				1
			ИЗ
				Документ.ПоступлениеБезналичныхД

Добавлено анонимнусом 19.10.2020 07:17:15

Просмотреть запись целиком.


&НаСервере
Процедура СформироватьОстаткиНаСервере()
	МассивСтруктурСтрок = Новый Массив;
	
	ОстаткиГП1 = РегистрыНакопления.СвободныеОстатки.Остатки(
		ТекущаяДата(),
		Новый Структура("Склад", Константы.Т_СкладГП.Получить())
	);
	
	ОстаткиГП2 = РегистрыНакопления.СвободныеОстатки.Остатки(

Добавлено анонимнусом 15.10.2020 12:27:22

Просмотреть запись целиком.


Задание1 = ВыполнитьЗадание1ВФоне();
Задание2 = ВыполнитьЗадание2ВФоне();
Задание3 = ВыполнитьЗадание3ВФоне();

Оповещение1 = ОписаниеОповещения("Задание1ПослеЗавершения");
Оповещение2 = ОписаниеОповещения("Задание2ПослеЗавершения");
Оповещение3 = ОписаниеОповещения("Задание3ПослеЗавершения");

Добавлено анонимнусом 14.10.2020 11:15:42

Просмотреть запись целиком.


ВЫБРАТЬ
	Таб.Ссылка,
	Таб.Ссылка.Подразделение
ИЗ
	Документ.ЭтапПроизводства2_2.ОбеспечениеМатериаламиИРаботами КАК Таб
ГДЕ
	Таб.Ссылка.Подразделение <> &Подразделение
	И Таб.evp_Назначение <> ЗНАЧЕНИЕ(Справочник.Назначения.ПустаяСсылка)
	И Таб.Ссылка.Проведен

Добавлено анонимнусом 14.10.2020 08:33:23

Просмотреть запись целиком.


Функция ОтгрузкаРазрешена(ТекДок) 
	Контрагент = ТекДок.Контрагент;
	СуммаЛимита = Контрагент.Клиент.ЛимитОтгрузки;
	Если СуммаЛимита=0 Тогда
		Возврат истина;
	КонецЕсли; 
	
	Запрос = Новый Запрос("ВЫБРАТЬ РАЗРЕШЕННЫЕ
	                      |	СУММА(ВзаиморасчетыСКонтрагентамиОстатки.СуммаВз

Добавлено анонимнусом 13.10.2020 06:02:43

Просмотреть запись целиком.


&НаСервере
Процедура СтартНаСервере()
	Таймаут = Объект.Таймаут;
	Команда = "Timeout /T " + Таймаут + " /NoBreak";
	Время.Очистить();
	ВремяЗавершения = ТекущаяДата() + Таймаут * 5;
	Итр = 0;
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	РеализацияТоваровУслуг.Ссылка

Добавлено анонимнусом 12.10.2020 08:17:46

Просмотреть запись целиком.


ВЫБРАТЬ
	ТоварыНаСкладахОстатки.Серия КАК Серия,
	ТоварыНаСкладахОстатки.Номенклатура КАК Номенклатура,
	ТоварыНаСкладахОстатки.Характеристика КАК Характеристика,
	ТоварыНаСкладахОстатки.Назначение КАК Назначение,
	ТоварыНаСкладахОстатки.Склад КАК Склад,
	ТоварыНаСкладахОстатки.Помещение КАК П

Добавлено анонимнусом 07.10.2020 14:59:59

Просмотреть запись целиком.


213

Добавлено анонимнусом 05.10.2020 04:19:19

Просмотреть запись целиком.


сообщить(1)

Добавлено анонимнусом 30.09.2020 15:13:48

Просмотреть запись целиком.


Документы_ПечатнаяФорма

#Область ПрограммныйИнтерфейс

// Возвращает печатную форму электронного документа.
// Если печатная форма не переопределена в ПМ, то формируется стандартная печатная форма.
//
// Параметры:
//    Документ - Структура - описание электронного документа (см. Контракт_Документ())
//
// Возвраща

Добавлено анонимнусом 30.09.2020 04:49:03

Просмотреть запись целиком.


 &НаСервере

Функция ЗарегистрироватьОбработку()

ОбъектЗначение = РеквизитФормыВЗначение("Объект");

ОбъектЗначение.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок[РегистрационныеДанные.Вид];
ОбъектЗначение.Наименование		= РегистрационныеДанные.Наименование;
ОбъектЗначение.Версия			=

Добавлено анонимнусом 29.09.2020 14:18:40

Просмотреть запись целиком.


 &НаСервере

Функция ЗарегистрироватьОбработку()

ОбъектЗначение = РеквизитФормыВЗначение("Объект");

ОбъектЗначение.Вид = Перечисления.ВидыДополнительныхОтчетовИОбработок[РегистрационныеДанные.Вид];
	ОбъектЗначение.Наименование		= РегистрационныеДанные.Наименование;
	ОбъектЗначение.Версия		

Добавлено анонимнусом 29.09.2020 14:17:51

Просмотреть запись целиком.


ВЫБРАТЬ РАЗРЕШЕННЫЕ
	Товары.ПодгруппаТовараНов КАК ПодгруппаТовара,
	Товары.ТорговаяМарка,
	Товары.ГруппаЗаказа КАК ГруппаЗаказа
ПОМЕСТИТЬ Комбо
ИЗ
	Справочник.Товары КАК Товары
ГДЕ
	НЕ Товары.ПометкаУдаления
	И Товары.СтатусТовара <> ЗНАЧЕНИЕ(Перечисление.СтатусТовара.Пассив)
	И НЕ Товары

Добавлено анонимнусом 24.09.2020 23:28:21

Просмотреть запись целиком.



&НаКлиенте
Процедура ВыполнитьЗамену(Команда)
	ВыполнитьЗаменуНаСервере();
КонецПроцедуры

&НаСервере
Процедура ВыполнитьЗаменуНаСервере()
	
	Для каждого Строка Из ТаблицаДокументов Цикл
	
		Если НЕ Строка.Использовать Тогда Продолжить; КонецЕсли;
		
		СтруктураДанных = ДанныеПредыдущи

Добавлено анонимнусом 24.09.2020 11:23:00

Просмотреть запись целиком.


Заголовок

	УстановитьПривилегированныйРежим(Истина);
	
	ЗаписьЖурналаРегистрации("Получены данные", УровеньЖурналаРегистрации.Информация,,,Запрос);
	
	ИмяСобытияДляЖурналаРегистрации = НСтр("ru='Входящее сообщение'", ОбщегоНазначения.КодОсновногоЯзыка());;
	
	Если Не ПолучитьФункциональнуюОпцию("Использ

Описание

Добавлено анонимнусом 23.09.2020 10:20:37

Просмотреть запись целиком.